The case of the missing cursor

Forums VoodooShield Support Forum General VoodooShield Discussions The case of the missing cursor

  • Post
    bellgamin
    Participant
    US
    I have tried to use VoodooShield (VS) ever since I subscribed to a Pro version back in November 23, 2019. I have tried, unsucessfully, to use every version and beta issued since that date, but to no avail.

    The issue is simple: everything works perfect about VS except for ONE issue: anytime I try to type any text while VS is running, my cursor disappears immediately after I type the first character. Thus, I have great security, thanks to VS, but I cannot do any typing online or offline.

    I’m on Win7 64bit. I hope this is fixable.

    0
    0
Viewing 13 replies - 1 through 13 (of 13 total)
  • Replies
    Dan
    Keymaster
    US
    Hmmmm, this is very odd, thank you for letting me know!  I imagine that if you hide the VS desktop shield gadget, the problem disappears, right?  You probably have another app that is requesting TopMost continually.  Let me see what I can do, thank you!
    1
    0
    bellgamin
    Participant
    US
    Thank you, Dan-sensei. I have my fingers crossed.

    You are CORRECT. When I hide VS’s desktop shield, the problem goes away. Odds fish!

    • This reply was modified 1 month, 1 week ago by bellgamin.
    • This reply was modified 1 month, 1 week ago by bellgamin.
    0
    0
    Dan
    Keymaster
    US
    Thank you, that helps!  Hopefully this will fix the issue, but if not I have a couple of other things I can try.

    VS 5.91 beta
    https://voodooshield.com/Download/InstallVoodooShield591beta.exe
    SHA-256: 8f8fe51bd5bd5d767dd012aaa786b0d1f70d3c152840066d442ea5fdc67f98e2

    1
    0
    bellgamin
    Participant
    US
    Downloaded the 5.91 beta just now. Will give it a spin forthwith and — THANKS to the nth for the incredibly fast response!

    By the way, whether or not this beta fixes this very minor blip, I am quite happy with hiding the shield and setting VS so it’s always On — a work-around I discovered after reading your 1st post above.

    I shall report back in 7.62 jiffies.

    Aloha from Hawaii.

    0
    0
    bellgamin
    Participant
    US
    I’m back. Installed the beta on top & …. you FIXED it. However, the shield disappears when I open my browser & does not reappear when I close the browser. Since this is probably an EXTREMELY rare issue (loss of cursor focus, that is), it might be better if you just ignore it. As stated above, I discovered a work-around (thanks to you) whereby I have no issue if I hide the shield & set VS to always On.

    Daniel… stay well, live long and — by all means — prosper. (^_^)

    Aloha,
    Bill

    • This reply was modified 1 month, 1 week ago by bellgamin.
    0
    0
    Dan
    Keymaster
    US
    Very cool, thank you for letting me know!  Please try this version, it might be even better.  I just put it on google drive for now to keep the number of beta releases to a minimum.

    https://drive.google.com/file/d/1C1Ujm7iOp_2_6YgPjEvNHs1c8geyUU40/view?usp=sharing

    1
    0
    bellgamin
    Participant
    US
    Your last beta fixed it perfectly to the nth!! Thanks muchly much. You are a programming genius! Will version 6 include this fix?
    0
    0
    Dan
    Keymaster
    US
    Very cool, thank you for letting me know!  Yeah, all future versions will include that fix, but if there is ever an issue please let me know.

    You can use that version until 5.92 is ready, which should be a day or so, it is basically 5.91 with the fix ;).

    0
    0
    Dan
    Keymaster
    US
    This should be the final version before the Web Apps changes, so please let me know if it is not working just right for you, thank you!

    VS 5.92 beta
    https://voodooshield.com/Download/InstallVoodooShield592beta.exe
    SHA-256: 217e9ffd19e4c50300619e27e3ed3b77cc2790b8d38b3865724d3eac7f3bad0d

    0
    0
    bellgamin
    Participant
    US
    Hola Dan-sensei,

    I installed 5.92 without incident. It’s running fair and straight with a following wind. As it now works, the shield is present on the desktop always, unless user sets Hide Desktop Shield on right-click menu of VS’s system tray icon. The shield is NOT visible when any other app takes the foreground.

    SUMMARY: If VS’s system tray icon is set to Show Desktop Shield, shield will always be visible on desktop but will NOT be visible when any app takes the foreground.

    My situation is very very rare. Other users may prefer VS’s shield to continue working as it did before. If so, I’ll simply use the work around that your comments led me to. It’s win-win either way.

    Aloha from Hawaii,
    Bill

    0
    0
    Dan
    Keymaster
    US
    Sorry, I am confused… is 5.92 running the same as the previous one from google drive?  I made a very small change in 5.92, but it should not have affected this issue.  But if the one from the google drive runs better than 5.92, please let me know and I will change it back, thank you!
    0
    0
    VecchioScarpone
    Participant
    AU
    Dan,

    installed over the top 5.91b then 592b, no worries.

    Thanks.

    "Today is yesterday's future - Carpe diem"

    0
    0
    bellgamin
    Participant
    US
    As far as I can tell, 5.92 is running the same as 5.91.
    0
    0
Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.